[Resolved] Strange problem with the ribbons using MIDI


I’ve encountered a problem with the Ribbons recently and don’t understand it.

Sometimes when i play, the wet sound totally disappears and the only way to have it back is to restart the pedal.

I’ve checked the filters of course and they are ok. Actually it happens on any preset, even factory. IF the pedal is full wet then there is suddenly nothing. I’ve got the last firmware installed. The power is supplied by a Ciocs DC7.

Any ideas ?


Do you have a midi and or expression pedal connected ?

That’s odd! Let’s get that sorted out.

Couple questions:

Are you using TRS cables into or out of Ribbons?

What comes next in the chain? What mixing and bypass options are you using?

I’ve heard of a couple people plugging a TRS cable into the output and then connecting a TRS cable into an audio interface line/mic input. If you do this the audio interface will subtract tip and ring and cancel the output signal.

Yeah, it’s on my pedalboard, connected to Morningstar MC6 Pro. There’s an expresion pedal but not sending anything to ribbons normally.

TRS cables both ends.

One side comes from Eventide H90, the other side to the Empress Echosystem.

That bug appears to be random. I’ve also noticed that, at some point, strange artifact can be heard in touch mode (for example Tape Stop or Broken Machine). Like high pitched noise.

I i restart the pedalboard, it works again normally.

Interesting! Your audio I/O setup seems good. The only thing I can think of is if Ribbons is receiving an unexpected MIDI CC message from the Morningstar MC6 Pro or there is an unreliable MIDI connection.

Which MIDI Type are you using for Ribbons? Type A, B, or CBA?

Type A and B are the most robust and reliable in my experience. I think the MC6 pro has connections on the side for one of those types which should work well. I have some emails from Morningstar that lead me to suspect there is a design flaw on their end specifically with the omniports and type A and B - they don’t follow the official MIDI spec.

I’m aware of a minor bug when you have TAPE NOISE turned up and you use Tape Stop and Broken Machine - there’s a slight high pitched whistle from TAPE NOISE being heavily modulated. I have it patched for the next update. That could be what you’re hearing.

I’m type A.

That said, i’d suspect MIDI too because messages are passing through. I agree with you with this design flaw from Morningstar but i’m connected via a midibox (piloted though DIN). That one works flawlessly (around 10 pedals connected).

But what kind of message could cause the wet sound to disappear ? If you’ve got ideas i could investigate.

About the tape noise it’s turned down, so my intuition would be around MIDI too, as if there was a “degradation” (funny when you think it’s the point <with this pedal).

I suspect MIDI too. When Ribbons receives MIDI messages the pots “lock” and MIDI takes over. Any CC sent to the high pass, low pass, or mix knob could cause what you’re describing (CC 0, 1 or 2). It makes sense that it would return back to normal after a power cycle because Ribbons would boot up to its last state before the CC was received.

If you have an audio interface with MIDI, you could connect the thru out of the Midibox to the interface and use some software such as MIDI Monitor to see what messages are being sent.

Yeah but i don’t use those CC (use PC and 15,16,17,18).

There are also MIDI clock messages passing (not for the Ribbons but it certainly receives them).

What i noticed is that it was difficult to link the Ribbons in the beginning. Partly because of the Morningstar thing, but also in the MIDIBOX. Initially, i had a chain Box → Boss RC5 → Neunaber Illumine → Ribbons but that failed most of the time. Then i switched to Box → Kernom MOHO → Ribbons and it works. But i might try Box → Ribbons and see if that helps.

Is it doing the same without the midi and expression pedal connected?

Difficult to say cause it’s really random. But i will try, that would point MIDI for sure.

Do you ever send “Bank Select”, “Mod Wheel”, or “Breath Controller” messages? Or maybe “bank up/down”?

Bank select is sometimes used with program change messages to select presets out of the normal 0-127 range.

Bank select is midi CC 0 and might be paired with a program change message. Maybe your MIDI controller is sending a bank select message?

No Mod Wheel or Breath for sure.
For bank select i checked and did not found one (could happen on the strymon i guess but i don’t use it).

That said, since i plugged the Ribbons directly into the Midibox the problem has not occured (for now).

Is it possible that if it’s too “far” on the MIDI chain there is a degradation of the messages ?

Cause when it was after 2 other pedals (via MIDI through) it was really reacting randomly (mainly no answers to PC or basic CCs). After just one other pedal it worked (same cable in both cases).

There are a few things that could be going on when something like this happens. One possibilty is a bad connection somewhere. MIDI does not have error checking. For example I once tried using a 10 foot TRS cable with the CBA MIDI Box + CBA option on Ribbons - the MIDI messages would get corrupted in transit resulting in totally unpredictable behavior. The issue stopped when I used a shorter cable.

If using Type A or Type B it could be that the device preceding Ribbons in the MIDI chain isn’t configured for MIDI through - I know the Illumine has a through mode and a controller mode.

Another possibility depending on someone’s setup is that the device preceding Ribbons isn’t capable of driving it. A lot of people think that MIDI is just a voltage message but it’s really a current loop. There is an official MIDI circuit which specifies that the through on a MIDI output should be able to drive 5mA. A number of products don’t follow this spec for whatever reason and limit the output which can unintentionally create problems with other devices.

The illumlne is configured for through.

What i did for now is putting the Moho after the Illumine (apparently it works) and the Ribbons alone on its port. For now it works but due to the random nature of this bug i’ll tell you in a while (and also try to record this “fry” sound on tape stop if it comes back.

1 Like