[In-Progress] Degradation looper struggles (and a bug?)

Hi! I have been using the degradation looper a lot lately and I have been struggling with it mainly for 2 reasons:

  1. While doing the initial loop record, hitting the Touch switch goes to play mode. I thought since it was a degradation looper with loop decay, it worked in a sound-on-sound way so it would start overdubbing after rec, but it plays instead, rendering Frippertronics-style looping very difficult to achieve without cuts in sound.
  2. The other thing is that there seems to be a bug with the recording buffer. In the manual, it states that when the max loop recording time is reached, it goes into overdub, so I was trying this to overcome the previous point by giving up on having control of the loop end point and trying to nail the length with the T2 knob before recording, but when I record, say, a 42-second loop and then it starts overdubbing by reaching the max length, I get a 10-second loop with the last I played (ie, from second 32 to second 42). Here is a link to a recording showing that: Dropbox - Ribbons degradation looper bug.mp3 - Simplify your life
  3. I find the degradation starts to kick in too early, making the sound quite muddy after, say 10 minutes if the T1 loop decay control is at max/unity. There is quite a high contrast between old non-fading layers and what’s being just recorded. Is there a way to control it so that no filter degradation occurs unless I manually engage the low-pass filter?

@jaakjensen have you encountered the bug on point #2 and/or know a way to work around the rest of the items?
Thanks in advance.

1 Like

Hi @ale.garciaiglesias thanks for posting. We just got back from a trip and I’m still playing catch up. I’ll look into all of this and get back to you real soon!

1 Like

Thanks for your patience! Here are my thoughts -

It works this way because it makes the Touch footswitch function consistent with the four-track looper. Tap to record, tap to stop and start playback. I can see how for your use case it would be smoother if the second tap activated overdubbing but IMO it would be counterintuitive to depart from the UI of the four-track looper.

I think Frippertronics-style looping is still very possible with Disintegration Loop. You just have to tap the footswitch one more time after you record the first loop to start recording again. If you tap 1 second after setting your loop length, then you would lose 1 second of potential overdubbing (I think that’s what you mean by “cuts in sound”). But your loop container remains same regardless of when you punch back in and you can overdub as many times as you want.

Sure enough - you found a bug! It seems the automatic jump to overdubbing isn’t functioning as expected when the max buffer length is >20 seconds. It works at 1x speed but not less than 1x speed. You can still record loops that are 20+ seconds long, it just doesn’t jump to overdubbing when the buffer fills up as expected.

I thought I tested this during development but I guess I missed it. Sorry about that and thanks for catching it.

I will investigate and roll out a firmware update with a fix as soon as possible. I’m trying really hard to kick off beta testing for our next pedal at the moment but I should be able to make time for this in the next couple weeks TBD. I’ll post here once it’s ready.

If you are using Disintegration Loop with the Saturation parameter enabled then you could try it with Compression instead. The anti-aliasing filters in the algorithm make the distortion sound smooth and analog but it can make Disintegration Loop a little darker after each repeat, even if Saturation is set to zero. There are no anti-aliasing filters when Compression is enabled so you should be able to get cleaner loops that way.

I might be able to tweak the feedback gain slightly to get it a little closer to unity so that there is less decay in general. I’ll check that out when I’m working on fixing the jump to overdub bug.

2 Likes

Thanks for your reply Jaak.

  1. Regarding Frippertronics looping, the problem is that sometimes between phrases there is a note decaying plus reverb and some delay, and if you double-hit the Touch footswitch, there’s still a minimal gap in the sound of the trails that is a bit annoying. It works if you record dry, which I don’t when I’m at Frippertronics.
  2. I’m glad that you may be able to fix the jump to overdubbing bug.
  3. I’m not using the saturation, I have the compressor enabled as per factory default, but I still find the loop layers become quite dark after a few repeats compared to the new audio I’m recording. This is regardless of the volume decay setting (which I’m keeping mostly at unity until I need some sonic “space”).

Anyhow, I get that, aside from the bug in item #2, you plan to keep the other items working as they are, which is reasonable :slight_smile: I had to ask just in case I missed something, but otherwise it seems I’ll have to look for another solution for end of chain looping.
Looking forward to the firmware update!

1 Like

This is interesting. I had never noticed any issue with this, probably because I usually have various effects on Ribbons activated when I’m using the Disintegration Looper. But I decided to load the Init preset and see what happened with a plain guitar loop, and I could hear it getting a little duller over time. It wasn’t very dramatic, and it took several cycles for it to become apparent, but it was happening. Then I tried it with a drum machine loop, and the darkening became quite obvious. After very few cycles, the hi-hat sound was almost obliterated. It’s as though there’s a slight lowpass filter on at all times. I don’t think this will affect the way I use the Disintegration Looper, but I thought it was worth verifying what @ale.garciaiglesias was saying.

@TallWalls @ale.garciaiglesias I’ll investigate this too when I look into the bug fix and see if there’s anything I can do to improve it.

@TallWalls thanks for confirming! As you mentioned, I can definitely notice point #3 that you’re referring to with instruments having more high-frequency content, such as voice and bowed instruments. Sometimes I want to make a loop with multiple layers for harmony before pausing the overdub and doing something else, and still after very few cycles, the last layers are much brighter and contrasting, and don’t “blend” seamlessly with the previous layers to form harmonies.

@jaakjensen I was under the impression and expectation that, since the Degradation Looper ran the pedal effects on each cycle, I should explicitly engage the low pass filter so that it affected the loop on each repeat in that way, but if I didn’t, then the loop would remain intact. Again, if it’s by design, it’s fine, I didn’t expect that due to the way it was explained in the manual.

Hi @jaakjensen, I was wondering if you could take a look into the issue no. 2, and besides that I also wanted to ask if it was possible to switch rec/play/dub order into rec/dub/play by introducing a new CC parameter for the Disintegration and Four Track Loopers. Those are the only things I seem to be needing at the moment for a looping solution and I would like to avoid spending on an extra pedal just for that (besides the fact that no other pedals are compact + decaying loops + long loop length + stereo + MIDI as Ribbons does).
I hope that is something straightforward to implement and if so, I really look forward to it.

Hey @ale.garciaiglesias - sorry to keep you waiting. I’ve been really focused on our next pedal these days and it’s taking up most of my time. I haven’t gotten very far with this.

#2 is a bug so I definitely owe an update. I can work on a fix sometime next week. I’ll also look into changing the footwsitch to do what you’re describing (just for Disintegration Loop). I think it does make sense for that mode.

I’ll share a file that you / anyone else can install and try it out.

3 Likes

Alright I fixed the “automatic jump to overdub when the buffer is filled” functionality when the speed control is less than 1x.

It seems like the variable used to monitor the loop length was in the wrong spot and ended up counting too fast. Oops! :sweat_smile: Sorry about that!

There are some things I need to sort out with the logic of the Touch footswitch so that it switches to overdubbing when the second tap is pressed, instead of playback. I’ll look into that tomorrow.

Thanks again for your patience on this! Feels good to be working on Ribbons firmware again.

2 Likes

Thanks for working on this Jaak, you’re the top one. It’s also interesting to hear a bit of the details being a programmer myself (although I work on web).

Still working on the logic switching / state machine for the footswitch.

It’s a little trickier than I expected.

One thing I’m still sorting out is how the Touch footswitch responds to a “quick tap” vs a “hold” now that I’m adding in the extra dub state.

Here is what I propose:

  • If the user does a quick tap, recording starts. Second tap switches to overdubbing. Third tap switches to playback. A quick double tap always clears the loop and starts back at the idle state.

  • If a user HOLDS Touch instead of quick tapping, recording starts. Then when they release the footswitch, it switches to playback. A quick double tap always clears the loop and starts back at the idle state. (This is the same as how this currently works).

In either scenario, once playback is reached you can punch back in and and overdub more - quick tap to latch overdubbing, or hold down Touch and then release for momentary.

How does that sound?

Hi Jaak,
At first thought, I would expect that holding Touch would start recording, and letting it go would switch to overdub, but this would be me with my mindset in which I loop my notes’ decay/reverb trails so that the loop sounds natural. On the other hand, I’m not sure I would use the hold for my workflow, and I’m trying to put myself in the mind of somebody doing some microlooping, or comparing it to the likes of Count to 5 or similar pedals, in which case I think it may make sense to use the workflow you propose.
TLDR; I guess it sounds good!

Now that I’ve said it out loud - I think it makes more sense to keep it consistent between both processes. Regardless of whether you tap or hold, it should do the same thing.

I’m still chipping away at this. Got a couple nuances to resolve but I’m making progress. Thanks for your patience.

Alright I’ve got it all working - I’m going to spend some time testing it tomorrow and then if all goes well I’ll share it here.

To be honest I was a little resistant to doing this change but now that I’ve done it and played around with it a bit I’m really into it. Thanks for the encouragement! I think others are going to like it too.

1 Like

Here you go. I think this should do everything you want it to do. I also resolved the issue of the repeats getting “dark” fairly quickly even with compression enabled. Instructions for updating are here.

  • Download this version if your unit was manufactured in 2022 and glows green/blue when you enter bootloader mode:
  • Download this version if your unit was manufactured in 2023 and glows purple/blue when you enter bootloader mode:

I’m open to incorporating this into a bigger release down the line (if others prefer it as well) but there are a couple things I need to sort out still:

  • Some kind of visual feedback to distinguish between initial recording and overdubbing. For now the LED flickers during recording and overdubbing, then ramps to show you your loop length once playback is reached.

  • There is a slight issue with using Disintegration Loop and MIDI now. The way I originally implemented the MIDI CC for the Touch footswitch it is 0 for off, and >=1 for on. This clashes with the new overdub approach, especially if someone has designed a MIDI controller that toggles between 0 and 1. If they press the button a couple times they will send: 1 to activate, then 0 to switch to overdub, then 1 to switch to playback, then 0 to overdub… It seems weird to me that 0 would be overdub. Anyway… I’ve come up with a bandaid for this particular update so that MIDI still works but I have an idea for something more elegant long term.

    • For now, if you use this update file and Ribbons has Disintegration Loop selected as the Touch Mode and you send a MIDI CC16 (Touch footswitch), it will respond as follows: 1 to start recording, 0 to toggle to overdub, 1 (ignored), 0 switch to playback, 1 switch to overdub, 0 switch to playback, and so on…
1 Like

Hi Jaak, sorry for the delay. Yesterday I found some time to try this new firmware and I have some feedback.

  1. I’m super glad to have rec going into overdub, I can make the looper work for me as it now records trails.
  2. The ignored MIDI CC16 message after overdubbing is messy in cases where while playing or overdubbing you erase the loop and then what to record again, sometimes it starts recording right away and sometimes doesn’t, depending on the previous combinantion/state. If the next message is to be ignored, it won’t. It makes things a bit annoying and have to remember what’s the MIDI controller state (sometimes I don’t remember it). I’m using a MIDI controller to toggle the Touch footswitch.
  3. There is a very strange bug sound/noise appearing sometimes when I start recording. It is very loud and scares me to the hell. I don’t know what else to describe it, and the issue doesn’t seem to be consistent, but it happens every couple of recordings. I will try to record it and attach it later, but it wasn’t happening before.
  4. The degradation can still be noticed if I don’t enable any degradation features of the pedal. The repeats become darker. I guess since it’s a degradation looper, it will still degrade anyway, so I guess it’s by design. It seems that when the recording is not engaged, that degradation stops, which is better now.
  5. I still wish that the behavior of rec → overdub → play could be implemented in the Four Track Looper since it would serve me better than Degradation Looper most of the times (unless I want to go frippertronics, which isn’t always the case). I know you mentioned already that it wasn’t going to be the case, but still whishing really hard since having a couple looping tracks that don’t degrade would be ideal and would prevent extra spending and an extra and bigger unit. As a side note, not feasible for this pedal but maybe for future products, I love what Shift Line did with some pedals such as Prism II or Astronaut V in which you can connect the pedal to the computer through USB and then be able to edit a config file to customize some functionality of the pedal. In this case, if we had something like that, we could edit such config file and configure the looper as rec/play/dub or rec/dub/play to taste. Just an idea for a future product. Anyhow, back to the point, if there’s any possibility of switching that with a MIDI CC message I would really love it.

That’s my feedback for now. Thank you for the test firmware, and please let me know if I can help with the noise bug.
Best!

Thanks for the feedback! Seems like I missed some things. I will review all this and get back to you soon.