Controlling Ribbons with Beebo

Has anyone out there tried controlling their Ribbons with the MIDI out from a Beebo? I’ve been experimenting with this and getting pretty poor results–but I’m not surprised by this, because TRS MIDI can be squirrelly and Beebo adds its own idiosyncrasies on top of that. My Beebo is from the period where they had Type B MIDI out, and I’ve had success with controlling Chase Bliss pedals with the Beebo even though Chase Bliss pedals don’t really use Type B MIDI. To get Ribbons to respond to the Beebo I had to change the jumpers to the Type B position (naturally), but I also had to change the MIDI channel to 2, because the Beebo seems to send its MIDI out on a channel that’s one off of what its MIDI module says. So if the Beebo says it’s sending on channel 1, it’s actually sending on channel 2. Intuitive, right?

After getting all that sorted out, I tried sending an LFO out to control the lowpass filter on the Ribbons, and it kind of worked for a while. It was supposedly sending a sine wave, but instead of a smooth oscillation the lowpass parameter was jumping around. I was tweaking things to try and get a better response when suddenly all kinds of weird stuff started happening–I can’t say exactly what, but it seemed like maybe Beebo was loading presets. All kinds of parameters changed, and nothing seemed to have anything to do with the sine wave LFO I was sending. I disconnected everything and tried again and the same thing happened, so I gave up on it. The problem is almost certainly on the Beebo side.

I have other ways of sending MIDI to Ribbons, but they’re Type A, and I thought it would be handy to have Ribbons set up as Type B because then I could also use it with my Microfreak. What I ended up doing was setting the jumpers in the Ribbons back to the Type A position so I could control it with my HX Stomp XL, and rigging a cable that swaps tip and ring so I can use the Microfreak. So I’m satisfied with my situation, but I thought I’d share my experiences here in case any other Beebo users are around.

The only time I have experienced this is when connecting the Chase Bliss MIDI box to Ribbons while Ribbons was set to Type A or Type B. So it’s possible this is a result of a mismatch in the wiring or maybe Beebo isn’t doing a proper “source/sink” for Type B MIDI.

I don’t think it’s an issue with Ribbons - Ribbons is just receiving garbled data and trying its best to make sense of it.

I’ll read through your post in more detail tomorrow and review the documentation from Beebo to see what setup might work best for Ribbons. It’s midnight here at Kinotone HQ! :sleeping: :white_heart:

1 Like

I did some tests in the midst of trying to get Beebo to communicate with Ribbons to make sure things were working as they should. With Ribbons set to Type B MIDI, I connected my Microfreak and everything worked as one would expect (the knobs on the Microfreak that are mapped to CC numbers controlled the correct parameters on the Ribbons). I also connected the Beebo to a Chase Bliss pedal, and it responded properly. However, that doesn’t tell us the whole story, because Chase Bliss doesn’t actually use Type B MIDI. This is further obfuscated by the fact that Poly’s website says that early Beebos used “Type B, 3.5 MM TRS. This is the same ring active pin out as Chase Bliss.” Which makes it seem like Poly is conflating Chase Bliss’s ring active/floating tip setup with actual Type B MIDI. But if Poly had actually left the tip disconnected I imagine a lot of users would be complaining. As far as I can tell, they’re not, but Poly does not have a nice centralized forum like Kinotone and Morningstar. You have to wade through their Facebook forum to get any information.

A more direct apples-to-apples way to test the Beebo’s MIDI output would be to connect it to the Microfreak, but I’m not literate enough in the ways of the Microfreak. The most obvious thing to do would be to send it MIDI clock, and maybe I should just try that.

Beebo’s MIDI output is all LFOs, envelopes, and sequencers (plus clock). There’s no way to send a specific value to a CC# as far as I can tell. And current-production Beebos use Type A, so people with newer Beebos will presumably have a different experience if they try to use Beebo with Ribbons.

Again, I have other ways to control Ribbons, so I’m not wanting for MIDI control, but I thought this Beebo behavior was interesting. Thanks for reading.

I think this is what’s happening. I could write an essay about this but I’ll keep it short. On your version of the Beebo, the signal is sent on the Ring and Sleeve of the TRS cable. This is not Type B.

From Beebo’s FAQ:

For Type B devices, the signal is sent out on the Ring and Tip of the TRS cable.

For Type A devices, the signal is sent out on the Ring and Tip of the TRS cable but the polarity is the opposite of Type B.

So, to use Ribbons with the early version of the Beebo I think you need to use the Type CBA connection on Ribbons. You may also need to use a short TRS cable (1 foot) for reliable data transmission but this varies from device to device.

Okay, I’ve done more testing, with interesting but not totally conclusive results.

First, I should clarify that I have a Beebo from the middle category–Type A input and Type B output. Hard to know if this comes into play at all.

I set Ribbons’s jumpers to CBA MIDI and connected it to Beebo, and that didn’t work. I was starting out with the same setup as described above, with an LFO modulating the value sent to CC# 1 (lowpass filter). Depending on what settings I used on the Beebo, I could get some random-seeming flickering from various parameters on Ribbons, but nothing close to proper functioning.

I switched the jumpers to Type B, and at first nothing would work at all. But then I changed the CC# at random (Beebo’s control are sliders, so I just stabbed at it) and started getting a smooth oscillation of the reverb mix/location parameter (turns out I had changed the CC# to 13). This makes an intriguing tremolo sound I’ll have to investigate more. From this point, any CC# I chose would oscillate properly. I tried sending simultaneous commands to two different CC#s, but that just made everything glitch out.

So it seems to me that the Beebo’s MIDI output is actually Type B. According to my multitester, the Beebo is putting out about 3.5v on the tip, and when MIDI is active the voltage on the ring varies by about 0.2v. My Microfreak puts out about 5.5v on the tip. I don’t know all that much about how all of this works, but it looks like devices tend to either put out 5v or 3.3v (interesting that both of these devices put out a little more than what they’re supposed to, but I can’t guess at what that might mean). I don’t know if this voltage difference matters to Ribbons.

But why did I get the poor response last time I tried this? As part of my testing today, I tried controlling my MOOD with the Beebo, which had always worked well. This time it didn’t work at all at first, and then I changed the CC# and it started working. Then I swapped the MIDI cable over to Ribbons and it didn’t work at first…and then it did. I thought maybe my cable was faulty, but I tried two different cables and got similar results. It’s hard to be certain about anything, because the problem is intermittent. It’s possible the MIDI out jack on my Beebo is bad, but I can’t think of a way of testing that.

Since the only vaguely consistent thing is the MIDI not working until I change the CC#, I’m guessing that the Beebo has a firmware issue that makes it not send MIDI data until I “wake it up” with a CC# change. That doesn’t explain why I got all the crazy glitching last time and not this time, but there are a lot of variables here and I might have had things set up slightly differently last time.

OK. In that case for Ribbons, the Type B jumper setting is probably what you want. I can shoot Beebo a quick email and ask for a wiring diagram too which might help to clarify.

It shouldn’t. With Type A and Type B it’s all about the current supplied, not the voltage. So as long as Beebo didn’t put a big resistor in series with the output then Ribbons should be able to receive a signal just fine.

I can’t say I’ve ever experienced that. :confused:

From Beebo:

“Ah okay. Just looked set the thread, so it’s working as type b which is what they say their version is so all good. On the Cc out module there’s a resolution option which might be the issue, basically it reduces how often messages are sent as some pedals can’t cope with fast messages (eventide h9). If that’s set too high it might only change on Cc number change.”

This message doesn’t quite make sense to me because Ribbons has a really fast MIDI scanning rate of 8kHz so it should be able to cope with the fastest possible messages.

Maybe try to adjust the resolution option for the CV to MIDI CC module anyway and see if this resolves things? See below. I would be curious to know what the setting options are for this parameter.


The Resolution parameter goes from 0.00 to 1.00. It defaults to 0.01, and since I’ve never known what it was supposed to do I’ve always just left it there. Testing it now, as I increase the value the MIDI messages get choppier, until at 1.00 it seems like there’s nothing being transmitted at all.

I’ve learned one thing that explains this “waking up” behavior. A little context: on the Beebo, I’m running an LFO module that outputs simulated CV (the Beebo has no CV out, so it’s just designed to control other modules within Beebo). This is connected to the CV To MIDI CC module, which is connected to the MIDI out port. Each of these modules have an on/off button. It turns out that if I change a parameter while the module is off, that parameter doesn’t actually get changed. When I turn the module on, it’s still putting out whatever it was putting out the last time it was on. So I would turn the MIDI out module off while I futzed with parameters, because I didn’t want to be sending random nonsense to Ribbons, and then I would turn the module on to see if what I changed helped matters. But that meant I was actually changing nothing.

So in my first post, where I talked about it working but not being a smooth sine wave, that was happening because I had changed the LFO from Random to Sine while the LFO module was off, so it was actually putting out a random LFO even though Sine was selected. If you make the changes while the modules are on, the changes are immediate and just as you expect. This goes against my instincts for whatever reason–it feels like making a change to software while it’s in production, if that makes sense–but I’ll get used to it.

In my last testing session, everything worked fine after I figured out that I had to leave all the modules on while I changed parameters. I even had two separate MIDI out modules going, modulating two parameters at once, and there were no issues. The only issue I had was that when I would change a CC# the previous parameter would stay at the last position/value sent by the Beebo until I cranked the knob around, and sometimes I would have to turn the knob more than once to get it back to zero. I noticed that Ribbons seemed hissier than usual at one point, and found that I had to turn the Noise knob back and forth a couple of times to zero it out. It was somehow stuck at a very very low level of Noise.

I wasn’t able to reproduce the glitches that happened in my previous sessions. It’s not as though those glitches just happened once–they happened several times. So I’m not sure why they were happening then and why they aren’t happening now. But at the moment, things are working fine, and this entire thread can be summed up as “things didn’t work, and then they did.” Maybe this will be useful to a Beebo user somewhere down the line, but I’m not holding my breath. Thanks, Jaak, for paying so much attention to this non-story.